【M1】Macでversion `GLIBC_2.29' not foundが発生した

先日M1 MacにRails7の環境を構築しようとしたところ下記のようなエラーが出ました

rails aborted! LoadError: /lib/aarch64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /usr/local/bundle/gems/nokogiri-1.13.1-aarch64-linux/lib/nokogiri/2.7/nokogiri.so) - /usr/local/bundle/gems/nokogiri-1.13.1-aarch64-linux/lib/nokogiri/2.7/nokogiri.so

Vagrantにrailsをインストールするもエラーがでる
https://ja.stackoverflow.com

こちらを見てみるとライブラリバージョンとOSバージョンの不一致が原因みたいでこっちでできることがバージョン下げることくらいしかなさそう....6系にしてみるか....


SNSでシェア

関連記事